Ale nie! Kde je JavaScript?
Váš webový prehliadač nemá povolený JavaScript alebo nepodporuje JavaScript. Ak chcete správne zobraziť túto webovú lokalitu, povoľte JavaScript vo svojom webovom prehliadači, alebo inovujte na webový prehliadač, ktorý podporuje JavaScript.

Fórum

upload vaccsich suborov

4 príspevky
1596 zobrazení
Naposledy aktualizované pred 2 rokmi
J
Člen 127
Odoslané pred 2 rokmi
#1
Ked chcem uploadovat v "Obsah > subory na stiahnutie" vacsie subory ako 2MB tak to nefunguje.
V "Obsah > Súbory na stiahnutie > Nastavenie" som si nastavil velkost na 150MB. Subory ale aj tak neviem pridat.
Po googleni som zistil, ze je potrebne upravit php.ini, tak som tak urobil
post_max_size = 150M
upload_max_filesize = 150M
A teraz to uz funguje.
Chcem sa len opytat, ci je lepsie to nastavit v php.ini (globalne) alebo to radsej nastavit v .htaccess
Kvido
Člen 293
Odoslané pred 2 rokmi
#2
Jde ti o upload downloadů, rozumím-li dobře?
Takže: Obsah/Downloady/Nastavení
Zde dej třeba změnit např. na:
Maximální velikost souboru: 1500 MB
Bude možno stahovat 15 G, což je dostačující, myslím.
na php.ini můžeš měnit pokud jsi na domácím localhostu, jiank musíš požádat svůj webhosting o navýšení.
V .htacces nedporučuji nic měnit.
J
Člen 127
Odoslané pred 2 rokmi
#3
Ano chcem uploadovat subory cez webove rozhranie phpfusion aby sa objavili v downloade pre uzivatelov.
Nastavit max. velkost cez web administraciu nestaci (ja osobne som to zmenil v php.ini) pretoze je to vlastny VPS a som root.
post_max_size = 150M
upload_max_filesize = 150M
Ale obecne by stacilo tie 2 riadky pridat do .htaccess a malo by to fungovat v ramci webu
Kvido
Člen 293
Odoslané pred 2 rokmi
#4
Zkus tedy v .htaccess:
php_value upload_max_filesize 150M

Pokud pak vyskočí hláška 500 - Interní chyba serveru , nemáte oprávnění nastavit tyto hodnoty pomocí .htaccess . Nutné pak se podívat na směrnici AllowOverride, zda má v nastavení All. Je-li totiž tato směrnice nastavena All, je v souborech povolena jakákoli směrnice, která má kontext .htaccess.

<Directory />
AllowOverride All
</Directory>


Jestli ti to není jasné, tak pro Tvého virtual host by mělo být v: /etc/apache2/sites-enabled/000-default.
A v něm je nutné pro zadaný web adresár povolit ten AllowOverride All a lépe i přidat parametre Options.
Takže možná tam máš:
<Directory /var/www/>
 Options Indexes FollowSymLinks MultiViews
 AllowOverride None
 Order allow,deny
 allow from all
 </Directory>

... a tedy změň na:
AllowOverride All

Po restartu Apache to bude všechno brát z .htacess
Upravil/a Kvido dňa 29/07/2018 06:35, pred 2 rokmi