Ale nie! Kde je JavaScript?
Váš webový prehliadač nemá povolený JavaScript alebo nepodporuje JavaScript. Ak chcete správne zobraziť túto webovú lokalitu, povoľte JavaScript vo svojom webovom prehliadači, alebo inovujte na webový prehliadač, ktorý podporuje JavaScript.

Fórum

Přechod na PHP-fusion 8 - pár dotazů

7 príspevkov
2583 zobrazení
Naposledy aktualizované pred 2 rokmi
G
Člen 6
Odoslané pred 2 rokmi
#1
Kvůli přechodu poskytovatele webu (IC.cz) na PHP 7 jsem musel aktualizovat své stránky georabbits.cz na PHP-fusion 8. Žádný velký problém jsem s tím neměl. Ještě jsem posléze nainstaloval i verzi 8.00.19.
Měl bych na zkušenější několik otázek:

1. Když dám odkaz na stránce "Pouze podhlavička", tak se odkaz zobrazí i v levém menu. To dříve nedělávalo.

2. V předchozí sedmičkové verzi mi bez problému fungoval na obrázky Lightbox. Teď jej nemůžu zprovoznit. Hlásí chybu HTTP 500 a web se vůbec nezobrazí.

3. V novém TinyMCE mi chybí nějaké funkce, které měla trojková řada. Nějak jsem nepochopil, jak doinstalovat další pluginy. Tak kdyby mě někdo nakopl co s tím, byl bych moc rád.
Jinak jsem si doinstaloval poslední verzi, protože ta dodávaná chybně zobrazovala menu a kontextovou nápovědu. S poslední verzí 4.9.2 už je to OK.

Za jakoukoliv radu moc děkuji.
Ivo

Jinak jsem za verzi 8 moc rád, protože verze 9 je pro mě tak trochu jiný level. Usmievajúci sa
RobiNN
Hlavný administrátor 780
Odoslané pred 2 rokmi
#2
1. opravené
2. pošli nejaký screen nech viem presnejšie alebo pozri zánam chyb
3. https://github.co...ee/8.00.20 tu je ďalšia verzia je tu aj nové TinyMCE
Skús nový https://lokeshdha...lightbox2/ alebo Colorbox http://www.jacklm.../colorbox/

Citovať

Jinak jsem za verzi 8 moc rád, protože verze 9 je pro mě tak trochu jiný level.


To som rad Usmievajúci sa kvôli tomu, že v9 je je iný level ako píšeš, sme vydali v8.
PHP-Fusion Development Manager
GitHub profil: GitHub
PHP Fusion témy: PF-Projects/PHP-Fusion-Themes
PHP Fusion infúzie: PF-Projects/PHP-Fusion-Infusions, php-fusion/Addons
G
Člen 6
Odoslané pred 2 rokmi
#3
Díky moc za rychlou reakci.

ad 1) perfektní, funguje :)

ad 2) poslední verzi Lightboxu jsem zkoušel.
Jakmile dám cokoliv do hlavičky (předpokládám, že je na to nově "header_includes.php" ), tak to skončí chybou HTTP 500 a web se vůbec nenačte. Chci zadat např. tento kód:
<link href="lightbox/lightbox.css" rel="stylesheet">


ad 3) Nové TinyMCE funguje bez problému.

A ještě menší problém. Sice to nepoužívám, ale po instalaci v. 8.00.20 v administraci nejsou funkční "Šablony e-mailů". Otevře se prázdná stránka.

Nový styl AdminLTE je povedený, asi u něj už zůstanu.:)

Takže ještě jednou díky.

Ivo
RobiNN
Hlavný administrátor 780
Odoslané pred 2 rokmi
#4
Skus toto. BASEDIR = root webu
add_to_head('<link href="'.BASEDIR.'lightbox/lightbox.css" rel="stylesheet">');


Citovať

po instalaci v. 8.00.20 v administraci nejsou funkční "Šablony e-mailů".


snag.gy/BexMw3.jpg
Mne to funguje.
PHP-Fusion Development Manager
GitHub profil: GitHub
PHP Fusion témy: PF-Projects/PHP-Fusion-Themes
PHP Fusion infúzie: PF-Projects/PHP-Fusion-Infusions, php-fusion/Addons
G
Člen 6
Odoslané pred 2 rokmi
#5

RobiNN napísal:

@RobiNN - Skus toto. BASEDIR = root webu
add_to_head('<link href="'.BASEDIR.'lightbox/lightbox.css" rel="stylesheet">');

Paráda! Toto funguje a lightbox je funkční.

Citovať

po instalaci v. 8.00.20 v administraci nejsou funkční "Šablony e-mailů".


snag.gy/BexMw3.jpg
Mne to funguje.


Na ty šablony se ještě mrknu. Asi jsem něco zblbnul.

Ještě jednou mockrát děkuji !

Ivo
Z
Člen 67
Odoslané pred 2 rokmi
#6
For information. I tested the update of the old site and could not immediately update the site on 02.07.07 to version 8.00.19 and above. I have an old PHP version 5.3.13, and I received the error message:

Citovať

Parse error: syntax error, unexpected '[' in Z:\home\editlw.ru\www\administration\upgrade.php on line 40

And only after I downloaded the file administration\upgrade.php from version 8.00, I started the update process in the admin panel. Perhaps it is worth reporting this more often. You can add to the readme or include in the archive with new versions the folder Upgrade_7.02.07_8.00.00.
RobiNN
Hlavný administrátor 780
Odoslané pred 2 rokmi
#7
@zizub Your PHP is too old. Check System requirements in readme file.
PHP-Fusion Development Manager
GitHub profil: GitHub
PHP Fusion témy: PF-Projects/PHP-Fusion-Themes
PHP Fusion infúzie: PF-Projects/PHP-Fusion-Infusions, php-fusion/Addons