Ale nie! Kde je JavaScript?
Váš webový prehliadač nemá povolený JavaScript alebo nepodporuje JavaScript. Ak chcete správne zobraziť túto webovú lokalitu, povoľte JavaScript vo svojom webovom prehliadači, alebo inovujte na webový prehliadač, ktorý podporuje JavaScript.

Fórum

Chyba inštalácie

13 príspevkov
4187 zobrazení
Naposledy aktualizované pred 2 rokmi
X
Člen
Nováčik
5
Odoslané pred 2 rokmi
#1
Zdravím mám problém pri inštalácii, nedokážem ani spustiť setup vypisuje tento problém.

Parse error: syntax error, unexpected '[' in /var/www/YYY/XXX/includes/core_functions_include.php on line 45


aký môže byť problém?
RobiNN
Hlavný administrátor
Management
1056
Odoslané pred 2 rokmi
#2
Na riadku 45 nič nie je https://github.co...de.php#L45

Akú máš PHP verziu? Odporúča sa používať čo najnovšiu PHP verziu, pre v9 aspoň 7.0. V9 funguje aj s 5.6 ale nie je zaručene, že všetko pôjde úplne bez chýb.

S týmto nemal ešte nikto nikdy problém.
X
Člen
Nováčik
5
Odoslané pred 2 rokmi
#3
stiahol som ju tu z webu PHP 09.03.00
RobiNN
Hlavný administrátor
Management
1056
Odoslané pred 2 rokmi
#4
PHP nie PHP-Fusion...
RobiNN
Hlavný administrátor
Management
1056
Odoslané pred 2 rokmi
#5
Vytvor súbor phpinfo.php spusti ho a pozri sa akú máš PHP verziu. Hneď ako prve hore to píše.

<?php
phpinfo();
X
Člen
Nováčik
5
Odoslané pred 2 rokmi
#6
Vieš mi poradiť ako to najrýchlejšie zistiť?
RobiNN
Hlavný administrátor
Management
1056
Odoslané pred 2 rokmi
#7
https://php-fusio...#post_1668 .....
X
Člen
Nováčik
5
Odoslané pred 2 rokmi
#8
napísalo mi to - PHP Version 5.3.3-7+squeeze19
RobiNN
Hlavný administrátor
Management
1056
Odoslané pred 2 rokmi
#9
No a pozeral si vôbec systémove požiadavky v súboru readme. Asi nie..

Minimálna PHP verzia je 5.6 odporúča sa 7.0 a novšie
Minimálna MySQL verzia je 5.6
Apache 2.2 alebo novšie

Zmeň PHP verziu alebo sa spýtaj poskytovateľa webhostingu.
X
Člen
Nováčik
5
Odoslané pred 2 rokmi
#10
Okej, pardon za blbé otázky nepozeral som sa máš pravdu. ďakujem za odpoveď
RobiNN
Hlavný administrátor
Management
1056
Odoslané pred 2 rokmi
#11
V pohode, skôr som zarazený, že v tejto dobe je ešte stále na nejakom hostignu archaické PHP 5.3. Tato verzia už roky nie je podporovaná. Ani PHP-Fusion 7 možno na tom už nespustíš.
Balin50
Člen
Veterán
873
Odoslané pred 2 rokmi
#12
to je asi všade. Ide o to ako je nastavené. Ja som tiež menil nastavenie. Ak o tom užívateľ nevie tak buď si nevšimol Help alebo FAQ kde to je popísané
https://ctrlv.sk/...
RobiNN
Hlavný administrátor
Management
1056
Odoslané pred 2 rokmi
#13
PHP 5.6 a nižšie už dávno nie sú podporované ale asi kašľu na bezpečnosť. Dobre 5.6 by sa ešte dalo, len nedávno ukončili podporu. Ale 5.5, 5.4 a 5.3 by už nemali mať nikde nainštalované. Prípadne by tam mali dať nejaké varovanie ako má Websupport.