Ale nie! Kde je JavaScript?
Váš webový prehliadač nemá povolený JavaScript alebo nepodporuje JavaScript. Ak chcete správne zobraziť túto webovú lokalitu, povoľte JavaScript vo svojom webovom prehliadači, alebo inovujte na webový prehliadač, ktorý podporuje JavaScript.

Fórum

Instalace php-fusion 9

19 príspevkov
4065 zobrazení
Naposledy aktualizované pred 3 rokmi
F
Člen 20
Odoslané pred 3 rokmi
#1
Dobrý den, pomuže mi někdo s instalaci? S php fusion 7 jsem nikdy nemela problem. Chci přejít na 9 ale na localhostu neumim nainstalovat spravnou verzi php atd. Na free webech se taky nejak nezobrazuje nic. A tak jsem si koupila domenu s hostigem a tam se mi spustila istalace, ale při zadávání přihlašovacích udajů pro mysql se mi databaaze nahrála, ale vypsalo mi to error 500. Psal jsem na podporu na forpsi.com, ale tam mi to prý spravili a ted to píše:

Forbidden

You don't have permission to access /install.php on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


Odpověd podpory byla:

Dobrý den,

v .htaccess byly tyto problémy:

Řádek začínající Cache nebyl zakomentovaný (nejedná se o direktivu)
Direktivu ForceType nelze u nás v .htaccess použít.

Nyní to varcí chybu 403 Forbidden, protože tam máte zakázaný přístup pro veškeré .php skripty (Deny)

Opravte tedy .htaccess
Nevím vůbec co teď v instalacce vůbec nemáte

Přeji krásný den a děkuji za odpověď
RobiNN
Hlavný administrátor 762
Odoslané pred 3 rokmi
#2
Vymaž v .htaccess

<FilesMatch "(?i).jpe?g$">
 ForceType image/jpeg
</FilesMatch>
<FilesMatch "(?i).gif$">
 ForceType image/gif
</FilesMatch>
<FilesMatch "(?i).png$">
 ForceType image/png
</FilesMatch>

PHP-Fusion Development Manager
GitHub profil: GitHub
PHP Fusion témy: PF-Projects/PHP-Fusion-Themes
PHP Fusion infúzie: PF-Projects/PHP-Fusion-Infusions, php-fusion/Addons
F
Člen 20
Odoslané pred 3 rokmi
#3
Děkuji
Ted to píše tohle:
Forbidden

You don't have permission to access / on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
RobiNN
Hlavný administrátor 762
Odoslané pred 3 rokmi
#4
Skús nastaviť všetkým súborom a priečinkom chmod 755 alebo 777
PHP-Fusion Development Manager
GitHub profil: GitHub
PHP Fusion témy: PF-Projects/PHP-Fusion-Themes
PHP Fusion infúzie: PF-Projects/PHP-Fusion-Infusions, php-fusion/Addons
F
Člen 20
Odoslané pred 3 rokmi
#5
Mel 755 ted mam 777 porad stejne, nemel bych spustit instalaci nejak znovu?
F
Člen 20
Odoslané pred 3 rokmi
#6
# Force utf-8 charset
AddDefaultCharset utf-8

# Security
ServerSignature Off

# Secure htaccess file
<Files .htaccess>
order allow,deny
deny from all
</Files>

# Secure inc file
<Files *.inc>
Order allow,deny
deny from all
</Files>

<FilesMatch .*\.php.*>
Order Deny,Allow
Deny from all
</FilesMatch>

# Protect config.php
<Files config.php>
order allow,deny
deny from all
</Files>

#Cache images for 7 days to soften network load
<IfModule mod_headers.c>
<FilesMatch "\.(ico|pdf|flv|jpg|jpeg|png|gif|js|css|swf)$">
Header set Cache-Control "max-age=290304000, public"
</FilesMatch>
</IfModule>

# Block Nasty Bots
<IfModule mod_setenvifno.c>
SetEnvIfNoCase ^User-Agent$ .*(craftbot|download|extract|stripper|sucker|ninja|clshttp|webspider|leacher|collector|grabber|webpictures) HTTP_SAFE_BADBOT
SetEnvIfNoCase ^User-Agent$ .*(libwww-perl|aesop_com_spiderman) HTTP_SAFE_BADBOT
SetEnvIfNoCase ^User-Agent$ .*(almaden|Anarchie|ASPSeek|attach|autoemailspider|BackWeb|Bandit|BatchFTP|BlackWidow|Bot\ mailto:|Buddy|bumblebee|CherryPicker|ChinaClaw|CICC|Collector|Copier|Crescent|Custo|DA|DIIbot|DISCo|DISCo\ Pump|Download\ Demon|Download\ Wonder|Downloader|Drip|DSurf15a|eCatch|EasyDL/2.99|EirGrabber|EmailCollector|EmailSiphon|EmailWolf|Express\ WebPictures|ExtractorPro|EyeNetIE|FileHound|FlashGet|GetRight|GetSmart|GetWeb!|gigabaz|Go\!Zilla|Go!Zilla|Go-Ahead-Got-It|gotit|Grabber|GrabNet|Grafula|grub-client|HMView|HTTrack|httpdown|ia_archiver|Image\ Stripper|Image\ Sucker|Indy*Library|InterGET|InternetLinkagent|Internet\ Ninja|InternetSeer.com|Iria|JBH*agent|JetCar|JOC\ Web\ Spider|JustView|larbin|LeechFTP|LexiBot|lftp|Link*Sleuth|likse|Link|LinkWalker|Mag-Net|Magnet|Mass\ Downloader|Memo|Microsoft.URL|MIDown\ tool|Mirror|Mister\ PiX|Mozilla.*Indy|Mozilla.*NEWT|Mozilla*MSIECrawler|MS\ FrontPage*|MSFrontPage|MSIECrawler|MSProxy|Navroad|NearSite|NetAnts|NetMechanic|NetSpider|Net\ Vampire|NetZIP|NICErsPRO|Ninja|Octopus|Offline\ Explorer|Offline\ Navigator|Openfind|PageGrabber|Papa\ Foto|pavuk|pcBrowser|Ping|PingALink|Pockey|psbot|Pump|QRVA|RealDownload|Reaper|Recorder|ReGet|Scooter|Seeker|Siphon|sitecheck.internetseer.com|SiteSnagger|SlySearch|SmartDownload|Snake|SpaceBison|sproose|Stripper|Sucker|SuperBot|SuperHTTP|Surfbot|Szukacz|tAkeOut|Teleport\ Pro|URLSpiderPro|Vacuum|VoidEYE|Web\ Image\ Collector|Web\ Sucker|WebAuto|[Ww]eb[Bb]andit|webcollage|WebCopier|Web\ Downloader|WebEMailExtrac.*|WebFetch|WebGo\ IS|WebHook|WebLeacher|WebMiner|WebMirror|WebReaper|WebSauger|Website|Website\ eXtractor|Website\ Quester|Webster|WebStripper|ebWhacker|WebZIP|Wget|Whacker|Widow|WWWOFFLE|x-Tractor|Xaldon\ WebSpider|Xenu|Zeus.*Webster|Zeus) HTTP_SAFE_BADBOT
Deny from env=HTTP_SAFE_BADBOT
</IfModule>
#Disable directory listing
#Options -Indexes



ErrorDocument 400 /error.php?code=400
ErrorDocument 401 /error.php?code=401
ErrorDocument 403 /error.php?code=403
ErrorDocument 404 /error.php?code=404
ErrorDocument 500 /error.php?code=500
RobiNN
Hlavný administrátor 762
Odoslané pred 3 rokmi
#7
Hneď vidím chybu prečo tam máš <?php a na konci ?> vymaž ich. Tieto tagy v .htaccess nemôžu byť.
PHP-Fusion Development Manager
GitHub profil: GitHub
PHP Fusion témy: PF-Projects/PHP-Fusion-Themes
PHP Fusion infúzie: PF-Projects/PHP-Fusion-Infusions, php-fusion/Addons
Upravil/a RobiNN dňa 18/10/2017 17:54, pred 3 rokmi
F
Člen 20
Odoslané pred 3 rokmi
#8
<php se tam udelalo kdyz jsem to vkládala do fora, to tam nemám
Kvido
Člen 283
Odoslané pred 3 rokmi
#9
Máte v .htaccess toto:

# Disable directory listing
Options -Indexes


Pokud ano přidejte ještě pod horní kód tohle:

Options +SymLinksIfOwnerMatch
<IfModule mod_rewrite.c>
   # Let PHP know mod_rewrite is enabled
   <IfModule mod_env.c>
      SetEnv MOD_REWRITE On
   </IfModule>
   RewriteEngine On
   RewriteBase /
   # Fix Apache internal dummy connections from breaking [(site_url)] cache
   RewriteCond %{HTTP_USER_AGENT} ^.*internal\ dummy\ connection.*$ [NC]
   RewriteRule .* - [F,L]
   # Exclude /assets and /manager directories and images from rewrite rules
   RewriteRule ^(administration|themes)/*$ - [L]
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteCond %{REQUEST_FILENAME} !-d
   RewriteCond %{REQUEST_FILENAME} !-l
   RewriteCond %{REQUEST_URI} !^/(administration|config|index.php)
   RewriteRule ^(.*?)$ index.php [L]
</IfModule>


Hele někteří webhosteři to maj slabé a nepodporují vše, hlavně nejnovější verze jako PHP 7 atd.
1/ Pokud ti web vůbec nenajede. Zalohuju si soubor.htaccess a pak jej smaž!
2/ Ten htacces se totiž natáhne, objeví v adresáři až po celkové aktivaci webu.
3/ Nastartuj web, co to udělá znovu. Případně vše vymaž a proveď čistou instalaci znovu.

Podle mně to brzdí hosting. Zeptej se jich, jestli podporují modrewrite, někteří také ne jako tu Direktivu ForceType nelze v .htaccess u nich použít, proto ji zakomentuj "zahrádkou" před řádek tedy takto: # a nezapomeň dát na chvíli instalace u htaccess 777. ak ihned vrať. A ještě máš 777 pro instalaci také u config.php, mrkní se.
RobiNN
Hlavný administrátor 762
Odoslané pred 3 rokmi
#10
@infoadmin jemu nič nejde, ty si tu dal kód na pekné url adresy (SEO). Teraz mu netreba aby bol funkčný mod rewrite.

Skús ešte vymazať .htaccess. Web by mal fungovať aj bez tohto súboru.
PHP-Fusion Development Manager
GitHub profil: GitHub
PHP Fusion témy: PF-Projects/PHP-Fusion-Themes
PHP Fusion infúzie: PF-Projects/PHP-Fusion-Infusions, php-fusion/Addons
Kvido
Člen 283
Odoslané pred 3 rokmi
#11
@Fightka
Ještě dodávám.
1/Jaký to je hosting, problémy jsou třeba na Endora.
2/ Máš v systému hostingu k dispozici PHP-verzi nejméně 5.5.35 a vyšší nejlépe 7.
Upravil/a RobiNN dňa 19/10/2017 10:20, pred 3 rokmi
F
Člen 20
Odoslané pred 3 rokmi
#12
endora mi nefungovala ale bylo to verzi php a jeste neco, tak jsem si domenu koupila. Ještě jsem nic nezkoušela. Tak se ozvu asi az zitra, ale moc dekuji za rady Hezký den Usmievajúci sa
F
Člen 20
Odoslané pred 3 rokmi
#13
O5 zdravím, smazala jsem htacess a funguje. :-) Akorád jsem nezadavala parametry pro přihlašení. Tak nevím jak se lognout
F
Člen 20
Odoslané pred 3 rokmi
#14
Nevite kde změnit člena na Hlavni administor v databazi nebo v kodu?
RobiNN
Hlavný administrátor 762
Odoslané pred 3 rokmi
#15
Spusti znovu inštaláciu tvojweb.cz/install.php a klikni na "Změna podrobností o primárním účtu"
PHP-Fusion Development Manager
GitHub profil: GitHub
PHP Fusion témy: PF-Projects/PHP-Fusion-Themes
PHP Fusion infúzie: PF-Projects/PHP-Fusion-Infusions, php-fusion/Addons
F
Člen 20
Odoslané pred 3 rokmi
#16
A jinak to nejde? V te istalaci se tam nedostanu zmizi to
F
Člen 20
Odoslané pred 3 rokmi
#17
Diky uz to jde, Najedou
F
Člen 20
Odoslané pred 3 rokmi
#18
A nevadí že tam není ten .htaccess?
Kvido
Člen 283
Odoslané pred 3 rokmi
#19
Nevadí.
Ten systémový soubor .htacces naběhne automaticky pokud budeš mít funkční mod rewrite po zapnutí superlinků. Ty slouží pro vytváření tzv, hezkých, velmi dobře čitelných URL adres.
Takže zatím máš URL, které končí u news Novinek asi takhle: .....news.php?readmore=3
Po zapnutí superlinků budeš mít na konci URL přesný název, třeba takhle: ......news/3/Test-clanku3
Zatím superlinky nezapínej, jako začátečník, abys neměla problémy. To je moje rada, než se systémem dokonale seznámíš více. Navíc, ještě není vypracován stoprocentní návod pro zapnutí superlinků.
Upravil/a Kvido dňa 23/10/2017 07:38, pred 3 rokmi