Ale nie! Kde je JavaScript?
Váš webový prehliadač nemá povolený JavaScript alebo nepodporuje JavaScript. Ak chcete správne zobraziť túto webovú lokalitu, povoľte JavaScript vo svojom webovom prehliadači, alebo inovujte na webový prehliadač, ktorý podporuje JavaScript.

Fórum

phpfusion za reverznym proxy

5 príspevkov
139 zobrazení
Naposledy aktualizované pred 19 dňami
J
Člen
Užívateľ
137
Odoslané pred 23 dňami
#1
V domacej LAN pouzivam 1x LAMP kde mam 5x virtualhost (IP 192.168.1.55)
Mam 2 dalsie LAMPy (192.168.1.56 a 192.168.1.57)
V LAN sieti mam reverzny proxy nginx (IP 192.168.1.54).

Na IP adresach (192.168.1.56, 192.168.1.57) s LAMP-ami mam klasicke vhosty s html webmi
Tie samozrejme zeniem cez reverzny proxy bez problemov (LAN aj WAN funguje super).

Na IP 192.168.1.55 mam vhosty
dokuwiki
nextcloud
vlastny php web
phpfusion
wordpress


Vsetky vhosty (zo vsetkych LAMPov) mam sifrovane TLS
Co sa tyka :
dokuwiki
nextcloud
vlastny php web

Tak tie bez problemov funguju samozrejme aj s platnym TLS sifrovanim.
Problem je s wordpress a phpfusion.
Jednoducho vobec nefunguju ani v LAN a ani z WAN (certbotom som generoval certifikaty pre obidva domeny (na ktorych bezi WP aj phpfusion)). Certbot nevygeneruje certifikaty, pokial neoveri, ze domeny existuju.

Zatial som patral po informaciach na WP a potrebujem nieco upravit v configu, lebo to nieco niekde zle smeruje a nefunguje to (zrejme nieco z hostom, ale este som to neriesil).

Sorry ja nie som programator a do kodu sa nevyznam, takze mozem upravovat configy sposobom, ze tam nieco nakopirujem/editujem a otestujem to.

Problem bude urcite niekde v configu, pretoze ked 5 webov/domen funguje a 2 nefunguju, tak problem vidim len tam

Zlúčené 23. apríl 2021 15:17:10:
Takze s WP sa mi to uz podarilo a funguje to v celku dobre. Podla toho bolo potrebne do konfiguraku zadat
if (strpos($_SERVER['HTTP_X_FORWARDED_PROTO'], 'https') !== false)
$_SERVER['HTTPS']='on';

bez toho potom poziadavky smerovalo do nejakej nekonecnej smicky
btw TLS mam ukoncene na reverznom proxy
RobiNN
Hlavný administrátor
Management
1020
Odoslané pred 23 dňami
#2
Skús ten kód pridať niekde tu ak to bude fungovať dám to do jadra
https://github.com/PHPFusion/PHPFusio...e.php#L123

Nemám dobre nastavený NGINX na localhoste tak nemám ako to otestovať.
PHPFusion Development Manager
GitHub profil: GitHub
PHPFusion témy: PF-Projects/PF-Themes
PHFFusion infúzie: PF-Projects/PF-Addons, PHPFusion/Addons
J
Člen
Užívateľ
137
Odoslané pred 23 dňami
#3
Ja to mam trocha inak na phpfusion a mam tam toto, takze neviem kde to mam pridat
// Force protocol change if https turned on main settings
if ($settings['site_protocol'] == 'https' && !isset($_SERVER['HTTPS'])) {
 $url = ((array)parse_url(htmlspecialchars_decode($_SERVER['REQUEST_URI']))) + [
 'path' => '',
 'query' => ''
 ];
 $fusion_query = [];
 if ($url['query']) {
 parse_str($url['query'], $fusion_query); // this is original.
 }
 $prefix = !empty($fusion_query ? '?' : '');
 $site_path = str_replace($settings['site_path'], '', $url['path']);
 $site_path = $settings['siteurl'].$site_path.$prefix.http_build_query($fusion_query, 'flags_', '&');
 redirect($site_path);
}
RobiNN
Hlavný administrátor
Management
1020
Odoslané pred 23 dňami
#4
Máš starú verziu fusionu. V starých verziách to robilo občas problémy.
PHPFusion Development Manager
GitHub profil: GitHub
PHPFusion témy: PF-Projects/PF-Themes
PHFFusion infúzie: PF-Projects/PF-Addons, PHPFusion/Addons
J
Člen
Užívateľ
137
Odoslané pred 19 dňami
#5
Aha, uz som dlhsie neaktualizoval. Ani presne neviem aku ver. mam, ale ked pridem z prace, tak to overim.
Myslis, ze by to mohlo po aktualizacii fungovat aj bez toho kodu ?

Zlúčené 24. apríl 2021 20:53:56:

RobiNN napísal:

@RobiNN - Skús ten kód pridať niekde tu ak to bude fungovať dám to do jadra
https://github.com/PHPFusion/PHPFusio...e.php#L123

Nemám dobre nastavený NGINX na localhoste tak nemám ako to otestovať.

Takze som aktualizoval aj phpfusion a vlozil som do maincore.php na oznacene miesto tento kod
if (strpos($_SERVER['HTTP_X_FORWARDED_PROTO'], 'https') !== false)
$_SERVER['HTTPS']='on';

Zda sa, ze to funguje

Zlúčené 27. apríl 2021 07:32:04:
Docasne sme to doriesili tu